Stay Updated
 

Vault Browser Security image

 

 



As of April 7th, Bank of the Pacific will no longer support Internet Explorer (IE 11) for access to our online banking platform.


What does this mean for our customers that are currently utilizing Internet Explorer as their browser?Woman_Lap_Top

Bank of the Pacific's online banking platform is supported by the following browsers: Chrome, Firefox, Safari or Microsoft’s Edge Browser.

You may upload any of these browsers from the following links: 

When you update your browser you'll have a more secure online banking experience, as well as peace of mind knowing you are doing your part to keep your financial information safe. As online fraud continues to evolve, browsers have to become more secure with each release to help ensure your safety. No matter what browser you use, make sure you have the latest version installed. It is also very important to ensure your Operating System is up-to-date. Make sure the operating system you are using is currently supported. If it is not a supported operating system, we recommend you purchase and install a new, supported one.

Stay Secure

Transport Layer Security (TLS) is an internet protocol used for encrypting communication between your device and servers. It is important that you keep your device operating system and browser updated to ensure your data is secure.

For steps to verify and update your TLS Settings - Click Here

Browser Information

Exactly what browsers/versions will provide the option for TLS 1.2 and higher?
The below browser versions will support the option to use TLS 1.2 and higher and are certified for use on our Online Banking.

Supported Browser           Windows 10              Mac OS  X 10.10 - Current Version

Internet Explorer 11                                    X
    (Please Note: Support Ends April 2020)                                                               
Chrome*                                                       X                                                      X
    
(Current Version plus the previous
      two versions are supported)  
Mozilla Firefox                                            X                                                        X
     (Current Version plus the previous
       two versions are supported)  
Microsoft EdgeTM                                                                                               
     (Current Version plus the previous
       two versions are supported)
Safari                                                                                                                 X
     (Current Version plus the previous
       two versions are supported)

*Google Chrome is the recommended browser.

Mobile App Information

What are the mobile device requirements to ensure use of TLS 1.2 and higher?

The below model and operating system versions will support the option to use TLS 1.2 and higher for use on our mobile app.

Mobile Device Model                Operating System

Android                                                         5.X or newer 

iOS                                                            iOS  10.X, 11.X, 12.X

The following mobile operating systems are not compatible with our Mobile App.
  • Windows
  • Blackberry
  • Kindle Fire